Your submission was sent successfully! Close

CVE-2014-9649

Published: 27 January 2015

Cross-site scripting (XSS) vulnerability in the management plugin in RabbitMQ 2.1.0 through 3.4.x before 3.4.1 allows remote attackers to inject arbitrary web script or HTML via the path info to api/, which is not properly handled in an error message.

Priority

Negligible

Status

Package Release Status
rabbitmq-server
Launchpad, Ubuntu, Debian
Upstream
Released (3.4.2)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(3.4.2-2)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(3.4.2-2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: https://github.com/rabbitmq/rabbitmq-web-dispatch/commit/7138dd778571334817af74db899f7e1b557e21da