CVE-2014-9556

Published: 03 February 2015

Integer overflow in the qtmd_decompress function in libmspack 0.4 allows remote attackers to cause a denial of service (hang) via a crafted CAB file, which triggers an infinite loop.

From the Ubuntu security team

It was discovered that cabextract incorrectly handled certain malformed CAB files. An attacker could use this issue to cause cabextract to hang, resulting in a denial of service.

Priority

Medium

Status

Package Release Status
cabextract
Launchpad, Ubuntu, Debian
Upstream
Released (1.4-5)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.6-1.1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.6-1.1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.6-1.1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.6-1.1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(1.6-1)
Ubuntu 14.04 ESM (Trusty Tahr) Needed

libmspack
Launchpad, Ubuntu, Debian
Upstream
Released (0.4-2)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(0.4-3)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(0.4-3)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.4-3)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(0.4-3)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(0.4-3)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)