CVE-2014-8958

Published: 30 November 2014

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.6, 4.1.x before 4.1.14.7, and 4.2.x before 4.2.12 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) database, (2) table, or (3) column name that is improperly handled during rendering of the table browse page; a crafted ENUM value that is improperly handled during rendering of the (4) table print view or (5) zoom search page; or (6) a crafted pma_fontsize cookie that is improperly handled during rendering of the home page.

Priority

Medium

Status

Package Release Status
phpmyadmin
Launchpad, Ubuntu, Debian
Upstream
Released (4:4.2.12-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(4:4.2.12-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4:4.2.12-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4:4.2.12-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4:4.2.12-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(4:4.2.12-1)
Ubuntu 14.04 ESM (Trusty Tahr) Needed