CVE-2014-8543

Published: 05 November 2014

libavcodec/mmvideo.c in FFmpeg before 2.4.2 does not consider all lines of HHV Intra blocks during validation of image height, which allows remote attackers to cause a denial of service (out-of-bounds access) or possibly have unspecified other impact via crafted MM video data.

Priority

Medium

Status

Package Release Status
ffmpeg
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(7:2.5.4-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(7:2.5.4-1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: http://git.videolan.org/?p=ffmpeg.git;a=commit;h=8b0e96e1f21b761ca15dbb470cd619a1ebf86c3e
libav
Launchpad, Ubuntu, Debian
Upstream
Released (0.8.17,11.2,10.6,9.18)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [6:9.18-0ubuntu0.14.04.1])
Patches:
Upstream: https://git.libav.org/?p=libav.git;a=commit;h=fc159ba88ea2dd1fa11e4ab6af8b574fc80db454
Upstream: https://git.libav.org/?p=libav.git;a=commit;h=fc159ba88ea2dd1fa11e4ab6af8b574fc80db454 (0.8)
mplayer
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(code not present)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [uses system ffmpeg])