CVE-2014-8355

Published: 31 October 2014

PCX parser code in ImageMagick before 6.8.9-9 allows remote attackers to cause a denial of service (out-of-bounds read).

From the Ubuntu security team

It was discovered that GraphicsMagick incorrectly handled certain image files. An attacker could possibly use this issue to cause a denial of service or other unspecified impact.

Priority

Low

CVSS 3 base score: 5.5

Status

Package Release Status
graphicsmagick
Launchpad, Ubuntu, Debian
Upstream
Released (8:6.8.9.9-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable

Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr)
Released (1.3.18-1ubuntu3.1)
Ubuntu 12.04 ESM (Precise Pangolin) Does not exist
(precise was needed)
Patches:
Upstream: http://sourceforge.net/p/graphicsmagick/code/ci/4426024497f9ed26cbadc5af5a5de55ac84796ff/
imagemagick
Launchpad, Ubuntu, Debian
Upstream
Released (8:6.8.9.9-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(8:6.8.9.9-2)
Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable
(8:6.8.9.9-2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [8:6.7.7.10-6ubuntu3.2])
Ubuntu 12.04 ESM (Precise Pangolin) Does not exist
(precise was released [8:6.6.9.7-5ubuntu3.5])
Patches:
Upstream: http://trac.imagemagick.org/changeset/16773
Upstream: https://github.com/ImageMagick/ImageMagick/commit/08f033c1dca2e660303c2fbc818076905adf3a8d