Your submission was sent successfully! Close

CVE-2014-8147

Published: 31 December 2014

The resolveImplicitLevels function in common/ubidi.c in the Unicode Bidirectional Algorithm implementation in ICU4C in International Components for Unicode (ICU) before 55.1 uses an integer data type that is inconsistent with a header file, which allows remote attackers to cause a denial of service (incorrect malloc followed by invalid free) or possibly execute arbitrary code via crafted text.

Priority

Medium

Status

Package Release Status
icu
Launchpad, Ubuntu, Debian
Upstream
Released (55.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (52.1-3ubuntu0.3)
Patches:
Upstream: http://bugs.icu-project.org/trac/changeset/37080