Your submission was sent successfully! Close

CVE-2014-6438

Published: 6 September 2017

The URI.decode_www_form_component method in Ruby before 1.9.2-p330 allows remote attackers to cause a denial of service (catastrophic regular expression backtracking, resource consumption, or application crash) via a crafted string.

Notes

AuthorNote
sbeattie
fixed in 1.9.3 and newer. ruby1.9.1 packages are not affected
because they are all ruby 1.9.3.
Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
ruby1.8
Launchpad, Ubuntu, Debian
precise Does not exist
(precise was needs-triage)
trusty Does not exist

upstream Needs triage

utopic Does not exist

vivid Does not exist

wily Does not exist

xenial Does not exist

yakkety Does not exist

zesty Does not exist

ruby1.9
Launchpad, Ubuntu, Debian
maverick Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

utopic Does not exist

vivid Does not exist

wily Does not exist

xenial Does not exist

yakkety Does not exist

zesty Does not exist

ruby1.9.1
Launchpad, Ubuntu, Debian
precise Does not exist
(precise was not-affected [1.9.2 only])
trusty Does not exist
(trusty was not-affected [1.9.2 only])
upstream
Released (1.9.2-p330)
utopic Not vulnerable
(1.9.2 only)
vivid Not vulnerable
(1.9.2 only)
wily Does not exist

xenial Does not exist

yakkety Does not exist

zesty Does not exist

ruby2.0
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was not-affected [1.9.2 only])
upstream Needs triage

utopic Not vulnerable
(1.9.2 only)
vivid Does not exist

wily Does not exist

xenial Does not exist

yakkety Does not exist

zesty Does not exist

ruby2.1
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

upstream Not vulnerable
(1.9.2 only)
utopic Not vulnerable
(1.9.2 only)
vivid Not vulnerable
(1.9.2 only)
wily Not vulnerable
(1.9.2 only)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

ruby2.2
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

upstream Not vulnerable
(1.9.2 only)
utopic Does not exist

vivid Does not exist

wily Not vulnerable
(1.9.2 only)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

ruby2.3
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

upstream Not vulnerable
(1.9.2 only)
utopic Does not exist

vivid Does not exist

wily Does not exist

xenial Not vulnerable
(1.9.2 only)
yakkety Not vulnerable
(1.9.2 only)
zesty Not vulnerable
(1.9.2 only)