CVE-2014-6430

Published: 20 September 2014

The SnifferDecompress function in wiretap/ngsniffer.c in the DOS Sniffer file parser in Wireshark 1.10.x before 1.10.10 and 1.12.x before 1.12.1 does not validate bitmask data, which allows remote attackers to cause a denial of service (application crash) via a crafted file.

Priority

Medium

Status

Package Release Status
wireshark
Launchpad, Ubuntu, Debian
Upstream
Released (1.12.1, 1.10.10)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.12.1+g01b65bf-2)
Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable
(1.12.1+g01b65bf-2)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(1.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1)
Patches:
Upstream: https://code.wireshark.org/review/#/c/4085/