CVE-2014-5270

Published: 18 August 2014

Libgcrypt before 1.5.4, as used in GnuPG and other products, does not properly perform ciphertext normalization and ciphertext randomization, which makes it easier for physically proximate attackers to conduct key-extraction attacks by leveraging the ability to collect voltage data from exposed metal, a different vector than CVE-2013-4576.

Priority

Medium

Status

Package Release Status
gnupg
Launchpad, Ubuntu, Debian
Upstream
Released (1.4.16-1)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(1.4.16-1ubuntu2.1)
Patches:
Upstream: http://git.gnupg.org/cgi-bin/gitweb.cgi?p=gnupg.git;a=commit;h=cad8216f9a0b33c9dc84ecc4f385b00045e7b496
libgcrypt11
Launchpad, Ubuntu, Debian
Upstream
Released (1.5.4-1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1.5.3-2ubuntu4.1)
Patches:
Upstream: http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git;a=commit;h=6c3598f1f6a6f2548b60a31ce3c0dd9885558a4f (bp)
Upstream: http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git;a=commit;h=62e8e1283268f1d3b6d0cfb2fc4e7835bbcdaab6
libgcrypt20
Launchpad, Ubuntu, Debian
Upstream
Released (1.6.0-2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [1.6.1-2ubuntu1])