Your submission was sent successfully! Close

CVE-2014-5256

Published: 05 September 2014

Node.js 0.8 before 0.8.28 and 0.10 before 0.10.30 does not consider the possibility of recursive processing that triggers V8 garbage collection in conjunction with a V8 interrupt, which allows remote attackers to cause a denial of service (memory corruption and application crash) via deep JSON objects whose parsing lets this interrupt mask an overflow of the program stack.

Priority

Medium

Status

Package Release Status
libv8
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

libv8-3.14
Launchpad, Ubuntu, Debian
Upstream Needed

Ubuntu 18.04 LTS (Bionic Beaver) Ignored
(libv8 not supported)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(libv8 not supported)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was ignored [libv8 not supported])

Notes

AuthorNote
mdeslaur
CVE is for nodejs, but nodejs package uses system
libv8
mikesalvatore
The Ubuntu Security Team does not support libv8

References