CVE-2014-4659

Published: 20 February 2020

Ansible before 1.5.5 sets 0644 permissions for sources.list, which might allow local users to obtain sensitive credential information in opportunistic circumstances by reading a file that uses the "deb http://user:pass@server:port/" format.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
ansible
Launchpad, Ubuntu, Debian
Upstream
Released (1.5.5+dfsg-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.6.5+dfsg-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(1.6.5+dfsg-1)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(1.5.4+dfsg-1)
Patches:
Upstream: https://github.com/ansible/ansible/commit/c4b5e46054c74176b2446c82d4df1a2610eddc08