Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2014-3971

Published: 25 December 2014

The CmdAuthenticate::_authenticateX509 function in db/commands/authentication_commands.cpp in mongod in MongoDB 2.6.x before 2.6.2 allows remote attackers to cause a denial of service (daemon crash) by attempting authentication with an invalid X.509 client certificate.

Notes

AuthorNote
mdeslaur
2.6+ only

Priority

Medium

Status

Package Release Status
mongodb
Launchpad, Ubuntu, Debian
lucid Not vulnerable
(1:1.2.2-1ubuntu1.1)
precise Not vulnerable
(1:2.0.4-1ubuntu2.1)
trusty Not vulnerable
(1:2.4.9-1ubuntu2)
upstream
Released (2.6.2)
utopic Not vulnerable
(1:2.6.3-0ubuntu5)