CVE-2014-3625

Published: 20 November 2014

Directory traversal vulnerability in Pivotal Spring Framework 3.0.4 through 3.2.x before 3.2.12, 4.0.x before 4.0.8, and 4.1.x before 4.1.2 allows remote attackers to read arbitrary files via unspecified vectors, related to static resource handling.

From the Ubuntu security team

It was discovered that Spring Framework incorrectly handled inputs. A remote attacker could possibly use this issue to read arbitrary files.

Priority

Medium

Status

Package Release Status
libspring-java
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(3.2.12-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(3.2.12-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(3.2.12-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(3.2.12-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(3.2.12-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(3.2.12-1)
Ubuntu 14.04 ESM (Trusty Tahr) Needed