Your submission was sent successfully! Close

CVE-2014-3594

Published: 19 August 2014

Cross-site scripting (XSS) vulnerability in the Host Aggregates interface in OpenStack Dashboard (Horizon) before 2013.2.4, 2014.1 before 2014.1.2, and Juno before Juno-3 allows remote administrators to inject arbitrary web script or HTML via a new host aggregate name.

Notes

AuthorNote
jdstrand
Horizon on Essex (Ubuntu 12.04) does not have the Host Aggregate
interface
Priority

Medium

Status

Package Release Status
horizon
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Not vulnerable
(code-not-present)
trusty Does not exist
(trusty was released [1:2014.1.2-0ubuntu1.1])
upstream Needs triage

Patches:
upstream: https://review.openstack.org/115313 (havana)
upstream: https://review.openstack.org/115311 (icehouse)
upstream: https://review.openstack.org/115310 (juno)