Your submission was sent successfully! Close

CVE-2014-3195

Published: 8 October 2014

Google V8, as used in Google Chrome before 38.0.2125.101, does not properly track JavaScript heap-memory allocations as allocations of uninitialized memory and does not properly concatenate arrays of double-precision floating-point numbers, which allows remote attackers to obtain sensitive information via crafted JavaScript code, related to the PagedSpace::AllocateRaw and NewSpace::AllocateRaw functions in heap/spaces-inl.h, the LargeObjectSpace::AllocateRaw function in heap/spaces.cc, and the Runtime_ArrayConcat function in runtime.cc.

Priority

Medium

Status

Package Release Status
chromium-browser
Launchpad, Ubuntu, Debian
artful
Released (38.0.2125.111-0ubuntu1.1103)
bionic
Released (38.0.2125.111-0ubuntu1.1103)
cosmic
Released (38.0.2125.111-0ubuntu1.1103)
lucid Ignored
(reached end-of-life)
precise Does not exist
(precise was ignored)
trusty Does not exist
(trusty was released [38.0.2125.111-0ubuntu0.14.04.1.1061])
upstream
Released (38.0.2125.101)
utopic
Released (38.0.2125.111-0ubuntu0.14.10.1.1103)
vivid
Released (38.0.2125.111-0ubuntu1.1103)
wily
Released (38.0.2125.111-0ubuntu1.1103)
xenial
Released (38.0.2125.111-0ubuntu1.1103)
yakkety
Released (38.0.2125.111-0ubuntu1.1103)
zesty
Released (38.0.2125.111-0ubuntu1.1103)
libv8
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

lucid Ignored
(reached end-of-life)
precise Does not exist
(precise was needed)
trusty Does not exist

upstream Needed

utopic Does not exist

vivid Does not exist

wily Does not exist

xenial Does not exist

yakkety Does not exist

zesty Does not exist

libv8-3.14
Launchpad, Ubuntu, Debian
artful Ignored
(reached end-of-life)
bionic Ignored
(libv8 not supported)
cosmic Ignored
(libv8 not supported)
lucid Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored [libv8 not supported])
upstream Needed

utopic Ignored
(reached end-of-life)
vivid Ignored
(reached end-of-life)
wily Ignored
(reached end-of-life)
xenial Ignored
(libv8 not supported)
yakkety Ignored
(reached end-of-life)
zesty Ignored
(reached end-of-life)
oxide-qt
Launchpad, Ubuntu, Debian
artful
Released (1.2.5-0ubuntu1)
bionic Does not exist

cosmic Does not exist

lucid Does not exist

precise Does not exist

trusty Does not exist
(trusty was released [1.2.5-0ubuntu0.14.04.1])
upstream
Released (1.2.5)
utopic
Released (1.2.5-0ubuntu1)
vivid
Released (1.2.5-0ubuntu1)
wily
Released (1.2.5-0ubuntu1)
xenial
Released (1.2.5-0ubuntu1)
yakkety
Released (1.2.5-0ubuntu1)
zesty
Released (1.2.5-0ubuntu1)