Your submission was sent successfully! Close

CVE-2014-3005

Published: 01 February 2018

XML external entity (XXE) vulnerability in Zabbix 1.8.x before 1.8.21rc1, 2.0.x before 2.0.13rc1, 2.2.x before 2.2.5rc1, and 2.3.x before 2.3.2 allows remote attackers to read arbitrary files or potentially execute arbitrary code via a crafted DTD in an XML request.

From the Ubuntu security team

It was discovered that Zabbix incorrectly handled certain XML files. A remote attacker could possibly use this issue to read arbitrary files or potentially execute arbitrary code.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
zabbix
Launchpad, Ubuntu, Debian
Upstream
Released (1:2.2.5+dfsg-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(1:2.2.5+dfsg-1ubuntu1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1:2.2.5+dfsg-1ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1:2.2.5+dfsg-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1:2.2.5+dfsg-1ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(1:2.2.5+dfsg-1ubuntu1)
Ubuntu 14.04 ESM (Trusty Tahr) Needed

Patches:
Upstream: https://support.zabbix.com/secure/attachment/28912/ZBX_8151_2_2_2.patch