Your submission was sent successfully! Close

CVE-2014-2745

Published: 11 April 2014

Prosody before 0.9.4 does not properly restrict the processing of compressed XML elements, which allows remote attackers to cause a denial of service (resource consumption) via a crafted XMPP stream, aka an "xmppbomb" attack, related to core/portmanager.lua and util/xmppstream.lua.

Priority

Medium

Status

Package Release Status
prosody
Launchpad, Ubuntu, Debian
Upstream
Released (0.9.4-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(0.9.4-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(0.9.4-1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)