Your submission was sent successfully! Close

CVE-2014-2744

Published: 11 April 2014

plugins/mod_compression.lua in (1) Prosody before 0.9.4 and (2) Lightwitch Metronome through 3.4 negotiates stream compression while a session is unauthenticated, which allows remote attackers to cause a denial of service (resource consumption) via compressed XML elements in an XMPP stream, aka an "xmppbomb" attack.

Priority

Medium

Status

Package Release Status
prosody
Launchpad, Ubuntu, Debian
Upstream
Released (0.9.4-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(0.9.4-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(0.9.4-1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)