Your submission was sent successfully! Close

CVE-2014-0207

Published: 9 July 2014

The cdf_read_short_sector function in cdf.c in file before 5.19, as used in the Fileinfo component in PHP before 5.4.30 and 5.5.x before 5.5.14, allows remote attackers to cause a denial of service (assertion failure and application exit) via a crafted CDF file.

Priority

Medium

Status

Package Release Status
file
Launchpad, Ubuntu, Debian
lucid
Released (5.03-5ubuntu1.3)
precise
Released (5.09-2ubuntu0.4)
saucy
Released (5.11-2ubuntu4.3)
trusty
Released (1:5.14-2ubuntu3.1)
upstream
Released (1:5.19-1)
Patches:
upstream: https://github.com/file/file/commit/6d209c1c489457397a5763bca4b28e43aac90391

php5
Launchpad, Ubuntu, Debian
lucid
Released (5.3.2-1ubuntu4.26)
precise
Released (5.3.10-1ubuntu3.13)
saucy
Released (5.5.3+dfsg-1ubuntu2.6)
trusty
Released (5.5.9+dfsg-1ubuntu4.3)
upstream Needed

Patches:

upstream: http://git.php.net/?p=php-src.git;a=commitdiff;h=4fcb9a9d1b1063a65fbeb27395de4979c75bd962