CVE-2014-0144

Published: 26 March 2014

QEMU before 2.0.0 block drivers for CLOOP, QCOW2 version 2 and various other image formats are vulnerable to potential memory corruptions, integer/buffer overflows or crash caused by missing input validations which could allow a remote user to execute arbitrary code on the host with the privileges of the QEMU process.

Priority

Medium

Status

Package Release Status
qemu
Launchpad, Ubuntu, Debian
Upstream
Released (1.7.2, 2.0)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(2.0.0~rc1+dfsg-0ubuntu3)
Patches:
Other: https://lists.gnu.org/archive/html/qemu-devel/2014-03/msg04994.html
Upstream: http://git.qemu.org/?p=qemu.git;a=commit;h=8c7de28305a514d7f879fdfc677ca11fbf60d2e9 (bp)
Upstream: http://git.qemu.org/?p=qemu.git;a=commit;h=d65f97a82c4ed48374a764c769d4ba1ea9724e97
Upstream: http://git.qemu.org/?p=qemu.git;a=commit;h=7b103b36d6ef3b11827c203d3a793bf7da50ecd6
Upstream: http://git.qemu.org/?p=qemu.git;a=commit;h=f56b9bc3ae20fc93815b34aa022be919941406ce
Upstream: http://git.qemu.org/?p=qemu.git;a=commit;h=97f1c45c6f456572e5b504b8614e4a69e23b8e3a
Upstream: http://git.qemu.org/?p=qemu.git;a=commit;h=24342f2cae47d03911e346fe1e520b00dc2818e0
Upstream: http://git.qemu.org/?p=qemu.git;a=commit;h=63fa06dc978f3669dbfd9443b33cde9e2a7f4b41
Upstream: http://git.qemu.org/?p=qemu.git;a=commit;h=6d4b9e55fc625514a38d27cff4b9933f617fa7dc
Upstream: http://git.qemu.org/?p=qemu.git;a=commit;h=a1b3955c9415b1e767c130a2f59fee6aa28e575b
Upstream: http://git.qemu.org/?p=qemu.git;a=commit;h=5dab2faddc8eaa1fb1abdbe2f502001fc13a1b21
Upstream: http://git.qemu.org/?p=qemu.git;a=commit;h=ce48f2f441ca98885267af6fd636a7cb804ee646
Upstream: http://git.qemu.org/?p=qemu.git;a=commit;h=2d51c32c4b511db8bb9e58208f1e2c25e4c06c85
qemu-kvm
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Other: https://lists.gnu.org/archive/html/qemu-devel/2014-03/msg04994.html