CVE-2014-0130

Published: 07 May 2014

Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the implicit-render implementation in Ruby on Rails before 3.2.18, 4.0.x before 4.0.5, and 4.1.x before 4.1.1, when certain route globbing configurations are enabled, allows remote attackers to read arbitrary files via a crafted request.

Priority

Medium

Status

Package Release Status
rails
Launchpad, Ubuntu, Debian
Upstream
Released (3.2.18, 4.0.5, 4.1.1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2:4.2.10-0ubuntu4)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(2:4.2.6-1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
rails-4.0
Launchpad, Ubuntu, Debian
Upstream
Released (4.0.5)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)