Your submission was sent successfully! Close

CVE-2014-0119

Published: 31 May 2014

Apache Tomcat before 6.0.40, 7.x before 7.0.54, and 8.x before 8.0.6 does not properly constrain the class loader that accesses the XML parser used with an XSLT stylesheet, which allows remote attackers to (1) read arbitrary files via a crafted web application that provides an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue, or (2) read files associated with different web applications on a single Tomcat instance via a crafted web application.

From the Ubuntu security team

It was discovered that the Tomcat XML parser incorrectly handled XML External Entities (XXE). A remote attacker could possibly use this issue to read arbitrary files. This issue only affected Ubuntu 14.04 LTS.

Notes

AuthorNote
mdeslaur
patch is intrusive
Priority

Low

Status

Package Release Status
tomcat6
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

lucid Ignored
(reached end-of-life)
precise Ignored
(end of ESM support, was needed)
saucy Ignored
(reached end-of-life)
trusty
Released (6.0.39-1ubuntu0.1)
upstream
Released (6.0.41-1)
utopic Not vulnerable
(6.0.41-1)
vivid Not vulnerable
(6.0.41-1)
wily Not vulnerable
(6.0.41-1)
xenial Not vulnerable
(6.0.41-1)
yakkety Does not exist

zesty Does not exist

Patches:
upstream: http://svn.apache.org/viewvc?view=revision&revision=1589640
upstream: http://svn.apache.org/viewvc?view=revision&revision=1593815
upstream: http://svn.apache.org/viewvc?view=revision&revision=1593821







tomcat7
Launchpad, Ubuntu, Debian
artful Not vulnerable
(7.0.53-1)
bionic Not vulnerable
(7.0.53-1)
cosmic Not vulnerable
(7.0.53-1)
disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

lucid Does not exist

precise Does not exist
(precise was needed)
saucy Ignored
(reached end-of-life)
trusty
Released (7.0.52-1ubuntu0.3)
upstream
Released (7.0.53-1)
utopic Not vulnerable
(7.0.53-1)
vivid Not vulnerable
(7.0.53-1)
wily Not vulnerable
(7.0.53-1)
xenial Not vulnerable
(7.0.53-1)
yakkety Not vulnerable
(7.0.53-1)
zesty Not vulnerable
(7.0.53-1)
Patches:



upstream: http://svn.apache.org/viewvc?view=revision&revision=1589763 (bp)
upstream: http://svn.apache.org/viewvc?view=revision&revision=1589851 (bp)
upstream: http://svn.apache.org/viewvc?view=revision&revision=1588199
upstream: http://svn.apache.org/viewvc?view=revision&revision=1589997
upstream: http://svn.apache.org/viewvc?view=revision&revision=1590028
upstream: http://svn.apache.org/viewvc?view=revision&revision=1590036
vendor: https://git.centos.org/blob/rpms!tomcat.git/f90819793e4da6c0cc3e7c19d29b48710e29d05b/SOURCES!tomcat-7.0.42-CVE-2014-0119.patch
tomcat8
Launchpad, Ubuntu, Debian
artful Not vulnerable
(8.0.9-1)
bionic Not vulnerable
(8.0.9-1)
cosmic Not vulnerable
(8.0.9-1)
disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

lucid Does not exist

precise Does not exist

saucy Does not exist

trusty Does not exist

upstream
Released (8.0.5-1)
utopic Not vulnerable
(8.0.9-1)
vivid Not vulnerable
(8.0.9-1)
wily Not vulnerable
(8.0.9-1)
xenial Not vulnerable
(8.0.9-1)
yakkety Not vulnerable
(8.0.9-1)
zesty Not vulnerable
(8.0.9-1)