Your submission was sent successfully! Close

CVE-2013-6051

Published: 14 December 2013

The bgp_attr_unknown function in bgp_attr.c in Quagga 0.99.21 does not properly initialize the total variable, which allows remote attackers to cause a denial of service (bgpd crash) via a crafted BGP update.

Notes

AuthorNote
jdstrand
per upstream (see Debian bug), this was is 0.99.21 only
Priority

Low

Status

Package Release Status
quagga
Launchpad, Ubuntu, Debian
lucid Not vulnerable
(0.99.20.1-0ubuntu0.10.04.3)
precise Not vulnerable
(0.99.20.1-0ubuntu0.12.04.3)
quantal Ignored
(reached end-of-life)
raring Not vulnerable
(0.99.22-1)
saucy Not vulnerable

trusty Does not exist
(trusty was not-affected)
upstream
Released (0.99.22-1)
utopic Not vulnerable

Patches:
upstream: http://git.savannah.gnu.org/gitweb/?p=quagga.git;a=commitdiff;h=8794e8d229dc9fe29ea31424883433d4880ef408