Your submission was sent successfully! Close

CVE-2013-4234

Published: 16 September 2013

Multiple heap-based buffer overflows in the (1) abc_MIDI_drum and (2) abc_MIDI_gchord functions in load_abc.cpp in libmodplug 0.8.8.4 and earlier allow remote attackers to cause a denial of service (memory corruption and crash) and possibly execute arbitrary code via a crafted ABC.

Priority

Medium

Status

Package Release Status
gst-plugins-bad0.10
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [uses system libmodplug])
libmodplug
Launchpad, Ubuntu, Debian
Upstream Not vulnerable
(1:0.8.8.4-4.1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1:0.8.9.0-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(1:0.8.8.5-2)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(1:0.8.8.4-4.1)