CVE-2013-4202

Published: 08 August 2013

The (1) backup (api/contrib/backups.py) and (2) volume transfer (contrib/volume_transfer.py) APIs in OpenStack Cinder Grizzly 2013.1.3 and earlier allows remote attackers to cause a denial of service (resource consumption and crash) via an XML Entity Expansion (XEE) attack. NOTE: this issue is due to an incomplete fix for CVE-2013-1664.

Priority

Medium

Status

Package Release Status
cinder
Launchpad, Ubuntu, Debian
Upstream
Released (1:2013.2~rc3)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(1:2013.2~rc3-0ubuntu1)
Patches:
Other: https://bugs.launchpad.net/ossa/+bug/1190229

Notes

AuthorNote
jdstrand
Ubuntu 12.10 not affected per upstream
fixed in updates of Ubuntu 13.04

References

Bugs