Your submission was sent successfully! Close

CVE-2013-2207

Published: 9 October 2013

pt_chown in GNU C Library (aka glibc or libc6) before 2.18 does not properly check permissions for tty files, which allows local users to change the permission on the files and obtain access to arbitrary pseudo-terminals by leveraging a FUSE file system.

From the Ubuntu security team

Martin Carpenter discovered that pt_chown in the GNU C Library did not properly check permissions for tty files. A local attacker could use this to gain administrative privileges or expose sensitive information.

Notes

AuthorNote
mdeslaur
patch disables building of pt_chown
We can't just remove pt_chown from older releases, as
unfortunately a lot of stuff still needs it, like lxc for
example. We'll need to identify them first and fix them at the
same time.

While this CVE was originally marked as fixed in 2.17-93ubuntu2,
it got reverted in 2.17-93ubuntu4.
Priority

Low

Status

Package Release Status
eglibc
Launchpad, Ubuntu, Debian
precise
Released (2.15-0ubuntu10.14)
trusty
Released (2.19-0ubuntu6.8)
upstream Needs triage

vivid Does not exist

wily Does not exist

xenial Does not exist

yakkety Does not exist

zesty Does not exist

Patches:
upstream: http://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commitdiff;h=e4608715e6e1dd2adc91982fd151d5ba4f761d69
glibc
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

upstream Needed

vivid Ignored
(reached end-of-life)
wily
Released (2.21-0ubuntu4.2)
xenial Not vulnerable
(2.23-0ubuntu1)
yakkety Not vulnerable
(2.23-0ubuntu1)
zesty Not vulnerable
(2.23-0ubuntu1)