CVE-2013-2099

Published: 16 May 2013

Algorithmic complexity vulnerability in the ssl.match_hostname function in Python 3.2.x, 3.3.x, and earlier, and unspecified versions of python-backports-ssl_match_hostname as used for older Python versions, allows remote attackers to cause a denial of service (CPU consumption) via multiple wildcard characters in the common name in a certificate.

Priority

Low

Status

Package Release Status
bzr
Launchpad, Ubuntu, Debian
Upstream
Released (2.6.0~bzr6574)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.6.0~bzr6574-1ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.6.0~bzr6574-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2.6.0~bzr6574-1ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(2.6.0~bzr6574-1ubuntu1)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(2.6.0~bzr6574-1ubuntu1)
Patches:
Upstream: http://bazaar.launchpad.net/~bzr-pqm/bzr/bzr.dev/revision/6574
linkchecker
Launchpad, Ubuntu, Debian
Upstream
Released (8.5-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(8.6-2)
Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(8.6-2)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(8.6-2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [8.6-2])
python-tornado
Launchpad, Ubuntu, Debian
Upstream
Released (2.4.1-3)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(3.2.0-1ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(3.2.0-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(3.2.0-1ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(3.2.0-1ubuntu1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [3.1.1-1ubuntu2])
python-urllib3
Launchpad, Ubuntu, Debian
Upstream
Released (1.6-2)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.6-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.6-2)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.6-2)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(1.6-2)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(1.6-2)
python2.7
Launchpad, Ubuntu, Debian
Upstream
Released (2.7.5-5)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.7.5-5ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.7.5-5ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2.7.5-5ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(2.7.5-5ubuntu1)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(2.7.5-5ubuntu1)
python3.1
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

python3.2
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: http://hg.python.org/cpython/rev/fafd33db6ff6 (trunk)
Upstream: http://hg.python.org/cpython/rev/b9b521efeba3 (3.2)
Upstream: http://hg.python.org/cpython/rev/c627638753e2 (3.3)
python3.3
Launchpad, Ubuntu, Debian
Upstream
Released (3.3.2-3)
Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

w3af
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
zeroinstall-injector
Launchpad, Ubuntu, Debian
Upstream
Released (2.3.3-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.3.3-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(2.3.3-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(2.3.3-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(2.3.3-1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [2.3.3-1])
Patches:
Upstream: https://github.com/0install/0install/commit/0c5b21d47b6007ac764430638a476418688bce16