Your submission was sent successfully! Close

CVE-2013-1953

Published: 9 December 2013

Integer underflow in the input_bmp_reader function in input-bmp.c in AutoTrace 0.31.1 allows context-dependent attackers to have an unspecified impact via a small value in the biSize field in the header of a BMP file, which triggers a buffer overflow.

From the Ubuntu security team

It was discovered an integer underflow in AutoTrace. An attacker could use this vulnerability to cause a denial of service.

Notes

AuthorNote
seth-arnold
sam2p included based on comment in OSS thread
mdeslaur
gimp was fixed by commit in 2006, we're not affected.
Priority

Medium

Status

Package Release Status
autotrace
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hardy Ignored
(reached end-of-life)
hirsute Does not exist

impish Does not exist

jammy Does not exist

lucid Ignored
(reached end-of-life)
oneiric Ignored
(reached end-of-life)
precise Does not exist
(precise was needed)
quantal Ignored
(reached end-of-life)
raring Ignored
(reached end-of-life)
saucy Ignored
(reached end-of-life)
trusty Does not exist
(trusty was released [0.31.1-16+deb7u1ubuntu0.1])
upstream
Released (0.31.1-16+nmu1)
utopic Ignored
(reached end-of-life)
vivid Not vulnerable
(0.31.1-16+nmu1)
wily Not vulnerable
(0.31.1-16+nmu1)
xenial Not vulnerable
(0.31.1-16+nmu1)
yakkety Not vulnerable
(0.31.1-16+nmu1)
zesty Not vulnerable
(0.31.1-16+nmu1)
gimp
Launchpad, Ubuntu, Debian
artful Not vulnerable

bionic Not vulnerable

cosmic Not vulnerable

disco Not vulnerable

eoan Not vulnerable

focal Not vulnerable

groovy Not vulnerable

hardy Ignored
(reached end-of-life)
hirsute Not vulnerable

impish Not vulnerable

jammy Not vulnerable

lucid Not vulnerable

oneiric Not vulnerable

precise Does not exist
(precise was not-affected)
quantal Not vulnerable

raring Not vulnerable

saucy Not vulnerable

trusty Does not exist
(trusty was not-affected)
upstream Needed

utopic Not vulnerable

vivid Not vulnerable

wily Not vulnerable

xenial Not vulnerable

yakkety Not vulnerable

zesty Not vulnerable

Patches:
upstream: https://git.gnome.org/browse/gimp/commit/?h=57f805a159874107c6c98
sam2p
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hardy Ignored
(reached end-of-life)
hirsute Does not exist

impish Does not exist

jammy Does not exist

lucid Ignored
(reached end-of-life)
oneiric Ignored
(reached end-of-life)
precise Does not exist
(precise was needed)
quantal Ignored
(reached end-of-life)
raring Ignored
(reached end-of-life)
saucy Ignored
(reached end-of-life)
trusty Does not exist
(trusty was needed)
upstream Needed

utopic Ignored
(reached end-of-life)
vivid Ignored
(reached end-of-life)
wily Ignored
(reached end-of-life)
xenial Ignored
(end of standard support, was needed)
yakkety Does not exist

zesty Does not exist