CVE-2013-1653

Published: 12 March 2013

Puppet before 2.6.18, 2.7.x before 2.7.21, and 3.1.x before 3.1.1, and Puppet Enterprise before 1.2.7 and 2.7.x before 2.7.2, when listening for incoming connections is enabled and allowing access to the "run" REST endpoint is allowed, allows remote authenticated users to execute arbitrary code via a crafted HTTP request.

Priority

High

Status

Package Release Status
puppet
Launchpad, Ubuntu, Debian
Upstream
Released (2.7.21, 3.1.1)