CVE-2012-5965

Published: 31 January 2013

Stack-based buffer overflow in the unique_service_name function in ssdp/ssdp_server.c in the SSDP parser in the portable SDK for UPnP Devices (aka libupnp, formerly the Intel SDK for UPnP devices) 1.3.1 allows remote attackers to execute arbitrary code via a long DeviceType (aka urn device) field in a UDP packet.

Priority

Medium

Status

Package Release Status
libupnp
Launchpad, Ubuntu, Debian
Upstream
Released (1:1.6.17-1.2)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(1:1.6.17-1.2)
Patches:
Vendor: http://www.debian.org/security/2013/dsa-2614
libupnp4
Launchpad, Ubuntu, Debian
Upstream
Released (1.8.0~svn20100507-1.2)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(1.8.0~svn20100507-1.2)
Patches:
Vendor: http://www.debian.org/security/2013/dsa-2615