Your submission was sent successfully! Close

CVE-2012-4566

Published: 20 November 2012

The DTLS support in radsecproxy before 1.6.2 does not properly verify certificates when there are configuration blocks with CA settings that are unrelated to the block being used for verifying the certificate chain, which might allow remote attackers to bypass intended access restrictions and spoof clients, a different vulnerability than CVE-2012-4523.

Priority

Medium

Status

Package Release Status
radsecproxy
Launchpad, Ubuntu, Debian
Upstream
Released (1.6.2-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(1.6.2-1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [1.6.2-1])
Patches:
Upstream: http://git.nordu.net/?p=radsecproxy.git;a=commit;h=3682c935facf5ccd7fa600644bbb76957155c680