Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2012-4435

Published: 22 October 2012

fwknop before 2.0.3 does not properly validate IP addresses, which allows remote authenticated users to cause a denial of service (server crash) via a long IP address.

Priority

Medium

Status

Package Release Status
fwknop
Launchpad, Ubuntu, Debian
hardy Does not exist

lucid Ignored
(end of life)
natty Ignored
(end of life)
oneiric Ignored
(end of life)
precise Ignored
(end of life)
quantal
Released (2.0.3-1)
raring Not vulnerable
(2.0.3-2ubuntu1)
saucy Not vulnerable
(2.0.3-2ubuntu1)
trusty Does not exist
(trusty was not-affected [2.0.3-2ubuntu1])
upstream
Released (2.0.3)
utopic Not vulnerable
(2.0.3-2ubuntu1)
vivid Not vulnerable
(2.0.3-2ubuntu1)
wily Not vulnerable
(2.0.3-2ubuntu1)
xenial Not vulnerable
(2.0.3-2ubuntu1)
yakkety Not vulnerable
(2.0.3-2ubuntu1)
zesty Not vulnerable
(2.0.3-2ubuntu1)
Patches:
upstream: http://www.cipherdyne.org/cgi-bin/gitweb.cgi?p=fwknop.git;a=commitdiff;h=f4c16bc47fc24a96b63105556b62d61c1ba7d799