Your submission was sent successfully! Close

CVE-2012-3587

Published: 19 June 2012

APT 0.7.x before 0.7.25 and 0.8.x before 0.8.16, when using the apt-key net-update to import keyrings, relies on GnuPG argument order and does not check GPG subkeys, which might allow remote attackers to install Trojan horse packages via a man-in-the-middle (MITM) attack.

Notes

AuthorNote
jdstrand
LP: #1013639 disabled net-update. LP: #1013681 tracks the work
needed to re-enable it safely
Priority

Critical

Status

Package Release Status
apt
Launchpad, Ubuntu, Debian
hardy
Released (0.7.9ubuntu17.6)
lucid
Released (0.7.25.3ubuntu9.13)
natty
Released (0.8.13.2ubuntu4.6)
oneiric
Released (0.8.16~exp5ubuntu13.5)
precise
Released (0.8.16~exp12ubuntu10.2)
upstream Needs triage