Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2012-3363

Published: 13 February 2013

Zend_XmlRpc in Zend Framework 1.x before 1.11.12 and 1.12.x before 1.12.0 does not properly handle SimpleXMLElement classes, which allows remote attackers to read arbitrary files or create TCP connections via an external entity reference in a DOCTYPE element in an XML-RPC request, aka an XML external entity (XXE) injection attack.

Priority

Medium

Cvss 3 Severity Score

9.1

Score breakdown

Status

Package Release Status
zend-framework
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hardy Ignored
(end of life)
hirsute Does not exist

impish Does not exist

jammy Does not exist

lucid Ignored
(end of life)
mantic Does not exist

natty Ignored
(end of life)
noble Does not exist

oneiric Ignored
(end of life)
precise Ignored
(end of life)
quantal Ignored
(end of life)
raring Ignored
(end of life)
saucy Ignored
(end of life)
trusty Does not exist
(trusty was needed)
upstream
Released (1.11.12)
utopic Ignored
(end of life)
vivid Ignored
(end of life)
wily Ignored
(end of life)
xenial Needed

yakkety Ignored
(end of life)
zesty Does not exist

zendframework
Launchpad, Ubuntu, Debian
artful Not vulnerable
(1.12.20+dfsg-1ubuntu1)
bionic Not vulnerable
(1.12.20+dfsg-1ubuntu1)
cosmic Not vulnerable
(1.12.20+dfsg-1ubuntu1)
disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hardy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

lucid Ignored
(end of life)
mantic Does not exist

natty Does not exist

noble Does not exist

oneiric Does not exist

precise Does not exist

quantal Does not exist

raring Does not exist

saucy Does not exist

trusty Does not exist

upstream
Released (1.12.0)
utopic Does not exist

vivid Does not exist

wily Does not exist

xenial Does not exist

yakkety Does not exist

zesty Not vulnerable
(1.12.20+dfsg-1ubuntu1)

Severity score breakdown

Parameter Value
Base score 9.1
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact None
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N