Your submission was sent successfully! Close

You have successfully unsubscribed! Close

CVE-2012-2688

Published: 20 July 2012

Unspecified vulnerability in the _php_stream_scandir function in the stream implementation in PHP before 5.3.15 and 5.4.x before 5.4.5 has unknown impact and remote attack vectors, related to an "overflow."

Priority

Low

Status

Package Release Status
php5
Launchpad, Ubuntu, Debian
hardy
Released (5.2.4-2ubuntu5.26)
lucid
Released (5.3.2-1ubuntu4.18)
natty
Released (5.3.5-1ubuntu7.11)
oneiric
Released (5.3.6-13ubuntu3.9)
precise
Released (5.3.10-1ubuntu3.4)
upstream
Released (5.4.5,5.3.15)
Patches:
upstream: http://git.php.net/?p=php-src.git;a=commit;h=7d04e0fb2ec8be9b1c4b16a9f0b4958f853597f1 (trunk)
upstream: http://git.php.net/?p=php-src.git;a=commit;h=fc74503792b1ee92e4b813690890f3ed38fa3ad5 (trunk)
upstream: http://git.php.net/?p=php-src.git;a=commit;h=7d04e0fb2ec8be9b1c4b16a9f0b4958f853597f1 (5.3)
upstream: http://git.php.net/?p=php-src.git;a=commit;h=fc74503792b1ee92e4b813690890f3ed38fa3ad5 (5.3)