Your submission was sent successfully! Close

CVE-2012-2652

Published: 18 June 2012

The bdrv_open function in Qemu 1.0 does not properly handle the failure of the mkstemp function, when in snapshot node, which allows local users to overwrite or read arbitrary files via a symlink attack on an unspecified temporary file.

Priority

Medium

Status

Package Release Status
kvm
Launchpad, Ubuntu, Debian
Upstream Needs triage

qemu
Launchpad, Ubuntu, Debian
Upstream Needs triage

qemu-kvm
Launchpad, Ubuntu, Debian
Upstream Needs triage

Patches:
Other: http://marc.info/?l=qemu-devel&m=133819025731504&w=2
Upstream: http://git.kernel.org/?p=virt/kvm/qemu-kvm.git;a=commit;h=eba25057b9a5e19d10ace2bc7716667a31297169
This vulnerability is mitigated in part by the use of symlink restrictions in Ubuntu.