CVE-2012-2384

Published: 22 May 2012

Integer overflow in the i915_gem_do_execbuffer function in drivers/gpu/drm/i915/i915_gem_execbuffer.c in the Direct Rendering Manager (DRM) subsystem in the Linux kernel before 3.3.5 on 32-bit platforms allows local users to cause a denial of service (out-of-bounds write) or possibly have unspecified other impact via a crafted ioctl call.

From the Ubuntu security team

Xi Wang discovered a flaw in the Linux kernel's i915 graphics driver handling of buffer_count on 32 bit systems. An unprivileged local attacker could leverage this flaw to cause a denial of service or potentially gain root privileges.

Priority

Low

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
Patches:
Introduced by 432e58edc9de1d9c3d6a7b444b3c455b8f209a7d
Fixed by 44afb3a04391a74309d16180d1e4f8386fdfa745
linux-armadaxp
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-aws
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-ec2
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-flo
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-fsl-imx51
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-gke
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-goldfish
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-grouper
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-hwe
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-hwe-edge
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-linaro-omap
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-linaro-shared
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-linaro-vexpress
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-lts-backport-maverick
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-lts-backport-natty
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-lts-backport-oneiric
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-lts-quantal
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-lts-raring
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-lts-trusty
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-lts-utopic
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-lts-vivid
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-lts-wily
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-lts-xenial
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-maguro
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-mako
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-manta
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-mvl-dove
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-qcm-msm
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-raspi2
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-snapdragon
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)
linux-ti-omap4
Launchpad, Ubuntu, Debian
Upstream
Released (3.4~rc5)