Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2012-1596

Published: 11 April 2012

The mp2t_process_fragmented_payload function in epan/dissectors/packet-mp2t.c in the MP2T dissector in Wireshark 1.4.x before 1.4.12 and 1.6.x before 1.6.6 allows remote attackers to cause a denial of service (application crash) via a packet containing an invalid pointer value that triggers an incorrect memory-allocation attempt.

Notes

AuthorNote
tyhicks
Versions affected: 1.4.0 to 1.4.11, 1.6.0 to 1.6.5

Priority

Negligible

Status

Package Release Status
wireshark
Launchpad, Ubuntu, Debian
hardy Not vulnerable

lucid Not vulnerable

maverick Not vulnerable

natty Ignored
(end of life)
oneiric Ignored
(end of life)
precise Not vulnerable
(1.6.6-1)
quantal Not vulnerable
(1.6.6-1)
raring Not vulnerable
(1.6.6-1)
upstream
Released (1.4.12, 1.6.6)
Patches:
upstream: http://anonsvn.wireshark.org/viewvc?view=revision&revision=40978