CVE-2012-0954

Published: 15 June 2012

APT 0.7.x before 0.7.25 and 0.8.x before 0.8.16, when using the apt-key net-update to import keyrings, relies on GnuPG argument order and does not check GPG subkeys, which might allow remote attackers to install altered packages via a man-in-the-middle (MITM) attack. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-3587.

Priority

Critical

Status

Package Release Status
apt
Launchpad, Ubuntu, Debian
Upstream Not vulnerable
(net-update not enabled by debian)