CVE-2012-0868

Published: 28 February 2012

CRLF injection vulnerability in pg_dump in PostgreSQL 8.3.x before 8.3.18, 8.4.x before 8.4.11, 9.0.x before 9.0.7, and 9.1.x before 9.1.3 allows user-assisted remote attackers to execute arbitrary SQL commands via a crafted file containing object names with newlines, which are inserted into an SQL script that is used when the database is restored.

Priority

Medium

Status

Package Release Status
postgresql-8.2
Launchpad, Ubuntu, Debian
Upstream Needs triage

postgresql-8.3
Launchpad, Ubuntu, Debian
Upstream
Released (8.3.18)
postgresql-8.4
Launchpad, Ubuntu, Debian
Upstream
Released (8.4.11)
postgresql-9.1
Launchpad, Ubuntu, Debian
Upstream
Released (9.1.3)