Your submission was sent successfully! Close

CVE-2011-5321

Published: 2 May 2016

The tty_open function in drivers/tty/tty_io.c in the Linux kernel before 3.1.1 mishandles a driver-lookup failure, which allows local users to cause a denial of service (NULL pointer dereference and system crash) or possibly have unspecified other impact via crafted access to a device file under the /dev/pts directory.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
lucid Ignored
(reached end-of-life)
precise Not vulnerable
(3.2.0-1.1)
trusty Not vulnerable
(3.11.0-12.19)
upstream
Released (3.2~rc1)
utopic Not vulnerable
(3.13.0-24.46)
vivid Not vulnerable
(3.16.0-23.31)
wily Not vulnerable
(3.19.0-15.15)
linux-2.6
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (3.2~rc1)
utopic Does not exist

vivid Does not exist

wily Does not exist

linux-armadaxp
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Not vulnerable
(3.2.0-1600.1)
trusty Does not exist

upstream
Released (3.2~rc1)
utopic Does not exist

vivid Does not exist

wily Does not exist

linux-ec2
Launchpad, Ubuntu, Debian
lucid Ignored
(reached end-of-life)
precise Does not exist

trusty Does not exist

upstream
Released (3.2~rc1)
utopic Does not exist

vivid Does not exist

wily Does not exist

linux-flo
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (3.2~rc1)
utopic Not vulnerable
(3.4.0-3.10)
vivid Not vulnerable
(3.4.0-3.15)
wily Not vulnerable
(3.4.0-3.15)
linux-fsl-imx51
Launchpad, Ubuntu, Debian
lucid Ignored
(reached end-of-life, does not affect buildd)
precise Does not exist

trusty Does not exist

upstream
Released (3.2~rc1)
utopic Does not exist

vivid Does not exist

wily Does not exist

linux-goldfish
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (3.2~rc1)
utopic Not vulnerable
(3.4.0-3.14)
vivid Not vulnerable
(3.4.0-4.23)
wily Not vulnerable
(3.4.0-4.23)
linux-grouper
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (3.2~rc1)
utopic Ignored
(reached end-of-life)
vivid Does not exist

wily Does not exist

linux-linaro-omap
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Ignored
(abandoned)
trusty Does not exist

upstream
Released (3.2~rc1)
utopic Does not exist

vivid Does not exist

wily Does not exist

linux-linaro-shared
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Ignored
(abandoned)
trusty Does not exist

upstream
Released (3.2~rc1)
utopic Does not exist

vivid Does not exist

wily Does not exist

linux-linaro-vexpress
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Ignored
(abandoned)
trusty Does not exist

upstream
Released (3.2~rc1)
utopic Does not exist

vivid Does not exist

wily Does not exist

linux-lts-quantal
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Not vulnerable
(3.5.0-18.29~precise1)
trusty Does not exist

upstream
Released (3.2~rc1)
utopic Does not exist

vivid Does not exist

wily Does not exist

linux-lts-raring
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Ignored
(was needs-triage now end-of-life)
trusty Does not exist

upstream
Released (3.2~rc1)
utopic Does not exist

vivid Does not exist

wily Does not exist

linux-lts-saucy
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Not vulnerable
(3.11.0-13.20~precise2)
trusty Does not exist

upstream
Released (3.2~rc1)
utopic Does not exist

vivid Does not exist

wily Does not exist

linux-lts-trusty
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Not vulnerable
(3.13.0-24.46~precise1)
trusty Does not exist

upstream
Released (3.2~rc1)
utopic Does not exist

vivid Does not exist

wily Does not exist

linux-lts-utopic
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Does not exist

trusty Does not exist
(trusty was not-affected [3.16.0-25.33~14.04.2])
upstream
Released (3.2~rc1)
utopic Does not exist

vivid Does not exist

wily Does not exist

linux-lts-vivid
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Does not exist

trusty Does not exist
(trusty was not-affected [3.19.0-18.18~14.04.1])
upstream
Released (3.2~rc1)
utopic Does not exist

vivid Does not exist

wily Does not exist

linux-maguro
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (3.2~rc1)
utopic Does not exist

vivid Does not exist

wily Does not exist

linux-mako
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (3.2~rc1)
utopic Not vulnerable
(3.4.0-5.28)
vivid Not vulnerable
(3.4.0-5.34)
wily Not vulnerable
(3.4.0-5.34)
linux-manta
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (3.2~rc1)
utopic Not vulnerable
(3.4.0-6.25)
vivid Not vulnerable
(3.4.0-6.29)
wily Not vulnerable
(3.4.0-6.29)
linux-mvl-dove
Launchpad, Ubuntu, Debian
lucid Ignored
(reached end-of-life)
precise Does not exist

trusty Does not exist

upstream
Released (3.2~rc1)
utopic Does not exist

vivid Does not exist

wily Does not exist

linux-qcm-msm
Launchpad, Ubuntu, Debian
lucid Ignored
(abandoned)
precise Ignored
(abandoned)
trusty Does not exist

upstream
Released (3.2~rc1)
utopic Does not exist

vivid Does not exist

wily Does not exist

linux-raspi2
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

upstream
Released (3.2~rc1)
vivid Does not exist

wily Not vulnerable
(4.2.0-1008.12)
linux-ti-omap4
Launchpad, Ubuntu, Debian
lucid Does not exist

precise Not vulnerable
(3.0.0-1402.3)
trusty Does not exist

upstream
Released (3.2~rc1)
utopic Does not exist

vivid Does not exist

wily Does not exist

Notes

AuthorNote
jdstrand
android kernels (flo, goldfish, grouper, maguro, mako and manta) are
not supported on the Ubuntu Touch 14.10 and earlier preview kernels
linux-lts-saucy no longer receives official support
linux-lts-quantal no longer receives official support

References

Bugs