Your submission was sent successfully! Close

CVE-2011-4364

Published: 2 December 2011

Buffer overflow in the Sierra VMD decoder in libavcodec in FFmpeg 0.5.x before 0.5.7, 0.6.x before 0.6.4, 0.7.x before 0.7.9 and 0.8.x before 0.8.8; and in Libav 0.5.x before 0.5.6, 0.6.x before 0.6.4, and 0.7.x before 0.7.3 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted VMD file, related to corrupted streams.

Notes

AuthorNote
mdeslaur
ffmpeg-extra in multiverse needs to have matching version
libav-extra is built with tarball produced by libav package
Priority

Medium

Status

Package Release Status
ffmpeg
Launchpad, Ubuntu, Debian
hardy Ignored
(reached end-of-life)
lucid
Released (4:0.5.1-1ubuntu1.3)
maverick
Released (4:0.6-2ubuntu6.3)
natty Does not exist

oneiric Does not exist

upstream Needs triage

Patches:
upstream: http://git.videolan.org/?p=ffmpeg.git;a=commit;h=c0cbe36b18ab3eb13a53fe684ec1f63a00df2c86

ffmpeg-extra
Launchpad, Ubuntu, Debian
hardy Does not exist

lucid
Released (4:0.5.1-1ubuntu1.3)
maverick
Released (4:0.6-2ubuntu3.3)
natty Does not exist

oneiric Does not exist

upstream Needs triage

libav
Launchpad, Ubuntu, Debian
hardy Does not exist

lucid Does not exist

maverick Does not exist

natty
Released (4:0.6.4-0ubuntu0.11.04.1)
oneiric
Released (4:0.7.3-0ubuntu0.11.10.1)
upstream
Released (0.7.3)
Patches:

upstream: http://git.libav.org/?p=libav.git;a=commit;h=c0cbe36b18ab3eb13a53fe684ec1f63a00df2c86
libav-extra
Launchpad, Ubuntu, Debian
hardy Does not exist

lucid Does not exist

maverick Does not exist

natty
Released (4:0.6.4-1ubuntu1)
oneiric
Released (4:0.7.3ubuntu0.11.10.1)
upstream Needs triage