Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2011-3464

Published: 22 July 2012

Off-by-one error in the png_formatted_warning function in pngerror.c in libpng 1.5.4 through 1.5.7 might allow remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via unspecified vectors, which trigger a stack-based buffer overflow.

Notes

AuthorNote
jdstrand
firefox and thunderbird 16 are not affected

Priority

Medium

Status

Package Release Status
chromium-browser
Launchpad, Ubuntu, Debian
hardy Does not exist

lucid Not vulnerable
(uses system libpng)
natty Not vulnerable
(uses system libpng)
oneiric Not vulnerable
(uses system libpng)
precise Not vulnerable
(uses system libpng)
upstream Needs triage

firefox
Launchpad, Ubuntu, Debian
hardy Ignored
(end of life)
lucid Not vulnerable

natty Not vulnerable

oneiric Not vulnerable

precise Not vulnerable

upstream Needs triage

libpng
Launchpad, Ubuntu, Debian
hardy Not vulnerable

lucid Not vulnerable

natty Not vulnerable

oneiric Not vulnerable

precise Not vulnerable

upstream Needs triage

thunderbird
Launchpad, Ubuntu, Debian
hardy Ignored
(end of life)
lucid Not vulnerable

natty Not vulnerable

oneiric Not vulnerable

precise Not vulnerable

upstream Needs triage