Your submission was sent successfully! Close

You have successfully unsubscribed! Close

CVE-2011-3004

Published: 30 September 2011

The JSSubScriptLoader in Mozilla Firefox 4.x through 6 and SeaMonkey before 2.4 does not properly handle XPCNativeWrappers during calls to the loadSubScript method in an add-on, which makes it easier for remote attackers to gain privileges via a crafted web site that leverages certain unwrapping behavior.

Priority

Medium

Status

Package Release Status
firefox
Launchpad, Ubuntu, Debian
hardy Ignored
(uses system xulrunner)
lucid Not vulnerable

maverick Not vulnerable
(3.6.23+build1+nobinonly-0ubuntu0.10.10.1)
natty
Released (7.0.1+build1+nobinonly-0ubuntu0.11.04.1)
upstream
Released (7.0)