Your submission was sent successfully! Close

CVE-2011-2192

Published: 23 June 2011

The Curl_input_negotiate function in http_negotiate.c in libcurl 7.10.6 through 7.21.6, as used in curl and other products, always performs credential delegation during GSSAPI authentication, which allows remote servers to impersonate clients via GSSAPI requests.

From the Ubuntu security team

Richard Silverman discovered that when doing GSSAPI authentication, libcurl unconditionally performs credential delegation, handing the server a copy of the client's security credential. (CVE-2011-2192)

Priority

Medium

Status

Package Release Status
curl
Launchpad, Ubuntu, Debian
Upstream
Released (7.21.7,7.21.6-2)
Patches:
Upstream: http://curl.haxx.se/curl-gssapi-delegation.patch