Your submission was sent successfully! Close

CVE-2011-2179

Published: 07 June 2011

Multiple cross-site scripting (XSS) vulnerabilities in config.c in config.cgi in (1) Nagios 3.2.3 and (2) Icinga before 1.4.1 allow remote attackers to inject arbitrary web script or HTML via the expand parameter, as demonstrated by an (a) command action or a (b) hosts action.

Priority

Medium

Status

Package Release Status
icinga
Launchpad, Ubuntu, Debian
Upstream
Released (1.4.1-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.10.3-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(1.10.3-1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [1.10.3-1])
Patches:
Upstream: https://git.icinga.org/?p=icinga-core.git;a=commit;h=cd5042266227d65e09f27036f65d2edb8295c0e7
nagios2
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

nagios3
Launchpad, Ubuntu, Debian
Upstream
Released (3.2.3-3)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(3.2.3-3)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(3.2.3-3)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [3.2.3-3])
Patches:
Fork: https://git.icinga.org/?p=icinga-core.git;a=commit;h=cd5042266227d65e09f27036f65d2edb8295c0e7