CVE-2011-1959

Published: 06 June 2011

The snoop_read function in wiretap/snoop.c in Wireshark 1.2.x before 1.2.17 and 1.4.x before 1.4.7 does not properly handle certain virtualizable buffers, which allows remote attackers to cause a denial of service (application crash) via a large length value in a snoop file that triggers a stack-based buffer over-read.

Priority

Low

Status

Package Release Status
wireshark
Launchpad, Ubuntu, Debian
Upstream
Released (1.4.7)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(1.6.0-1)
Patches:
Upstream: http://anonsvn.wireshark.org/viewvc?view=revision&revision=37068