Your submission was sent successfully! Close

CVE-2011-1829

Published: 13 July 2011

APT before 0.8.15.2 does not properly validate inline GPG signatures, which allows man-in-the-middle attackers to install modified packages via vectors involving lack of an initial clearsigned message.

Notes

AuthorNote
mdeslaur
only apt in natty+ support InRelease files
Priority

High

Status

Package Release Status
apt
Launchpad, Ubuntu, Debian
hardy Not vulnerable
(code not present)
lucid Not vulnerable
(code not present)
maverick Not vulnerable
(code not present)
natty
Released (0.8.13.2ubuntu4.1)
upstream Needs triage