Your submission was sent successfully! Close

CVE-2011-1168

Published: 11 April 2011

Cross-site scripting (XSS) vulnerability in the KHTMLPart::htmlError function in khtml/khtml_part.cpp in Konqueror in KDE SC 4.4.0 through 4.6.1 allows remote attackers to inject arbitrary web script or HTML via the URI in a URL corresponding to an unavailable web site.

Priority

Medium

Status

Package Release Status
kde4libs
Launchpad, Ubuntu, Debian
dapper Does not exist

hardy Ignored
(reached end-of-life)
karmic
Released (4:4.3.2-0ubuntu7.3)
lucid
Released (4:4.4.5-0ubuntu1.1)
maverick
Released (4:4.5.1-0ubuntu8.1)
upstream
Released (4.6.2)
Patches:
upstream: http://quickgit.kde.org/?p=kdelibs.git&a=commitdiff&h=afaaf242a30654b61d996e66a3016fcf2a543cd9