Your submission was sent successfully! Close

CVE-2011-0421

Published: 19 March 2011

The _zip_name_locate function in zip_name_locate.c in the Zip extension in PHP before 5.3.6 does not properly handle a ZIPARCHIVE::FL_UNCHANGED argument, which might allow context-dependent attackers to cause a denial of service (NULL pointer dereference) via an empty ZIP archive that is processed with a (1) locateName or (2) statName operation.

Notes

AuthorNote
sbeattie
php 5.1 in dapper did not include the zip library
Priority

Low

Status

Package Release Status
libzip
Launchpad, Ubuntu, Debian
dapper Does not exist

hardy Ignored
(reached end-of-life)
karmic Ignored
(reached end-of-life)
lucid Ignored
(reached end-of-life)
maverick Ignored
(reached end-of-life)
natty Ignored
(reached end-of-life)
oneiric Ignored
(reached end-of-life)
precise Not vulnerable
(0.10-1)
quantal Not vulnerable
(0.10-1)
raring Not vulnerable
(0.10-1)
upstream
Released (0.10)
Patches:
upstream: http://hg.nih.at/libzip/?fd=13654bfdc88c;file=lib/zip_name_locate.c

php5
Launchpad, Ubuntu, Debian
dapper Not vulnerable

hardy
Released (5.2.4-2ubuntu5.15)
karmic
Released (5.2.10.dfsg.1-2ubuntu6.9)
lucid
Released (5.3.2-1ubuntu4.8)
maverick
Released (5.3.3-1ubuntu9.4)
natty
Released (5.3.5-1ubuntu7.1)
oneiric Not vulnerable
(5.3.6-11ubuntu1)
precise Not vulnerable
(5.3.6-11ubuntu1)
quantal Not vulnerable
(5.3.6-11ubuntu1)
raring Not vulnerable
(5.3.6-11ubuntu1)
upstream
Released (5.3.6)
Patches:

upstream: http://svn.php.net/viewvc/?view=revision&revision=307867